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    ARC 4: Error "CAF-WRN-2082"

    • Article Type: General
    • Product: Aleph
    • Product Version: 4

    Description

    In the ARC portal the error "CAF-WRN-2082" is displayed

    In /c10/logs/cogserver.log you can find the following errors:
     

    QE-DEF-0285 The logon failed
    QE-DEF-0323 The DSN(ODBC)/ServiceName is invalid.
    RQP-DEF-0068 Unable to connect to at least one database during a multi-database attach to 1 database(s) in: Aleph_Reporting
    UDA-SQL-0031 Unable to access database "Aleph_Reporting"
    UDA-SQL-0532 Data Source is not accessible: "ARC41"


    Cause:
    Wrong configuration of SQL*Net string in Aleph_reporting
    Mismatch between tnsnames.ora and ARC portal definition

    Resolution


    Change SQL*Net string or tnsnames.ora definition to match.

    1. Connect as administrator
    2. Launch IBM Cognos Administration
    3. Go to Configuration / Data sources
    Directory > Cognos
    4. Choose Aleph_reporting
    5. Click on 'More ...' / Set Properties
    6. Go to tab Connection
    7. Click on the pencil icon to edit the Connection string
    8. Adapt the SQL*Net connection string
    9. Save and Test the connection.

    In case of doubt contact your Ex Libris Support for detailed instructions.
    Status should be 'Succeeded'

    Additional Information

    Example from /exlibris/app/oracle/product/11r2/network/admin/tnsnames.ora

     

    arc.arc4=(description=
                 (address=
                     (protocol=ipc)
                      (key=arc4))
                 (address=
                     (protocol=tcp)
                     (host=il-arc02)
                     (port=1521))
     (connect_data=(service_name=arc4.il-arc02.corp.exlibrisgroup.com)(server=DEDICATED)))

     

    In the example above the SQL*Net connection string is: arc.arc4

     

     


    • Article last edited: 19-July-2016