Skip to main content
ExLibris
  • Subscribe by RSS
  • Ex Libris Knowledge Center

    Aleph 22: ELIB related programs not properly installed during Service Pack installation

    • Article Type: General
    • Product: Aleph
    • Product Version: 22

    Problem Symptoms:
    Various ELIB related programs result in errors or behave differently from earlier versions.

    Cause:
    Service Pack installation for customers in region ELIB did not work properly after using Aleph installation kit

    Resolution:
    Run the following steps to correct the ELIB programs and upgrade to Aleph 22.1 Minor release
    1. Uninstall last SP
    2. Create a temporary directory for SP download.
    E.g /exlibris/aleph/a22_1/alephm/scratch/
    3. Change directory to the temporary directory.
    E.g: cd /exlibris/aleph/a22_1/alephm/scratch/
    4. Download SP for ELIB customers to the temporary directory.
    E.g:
    wget ftp://ver22_sp:4pgrade@ftp.exlibris.co.il/ALEPH-ELIB-ServicePack-1-2123-Bin-Linux.tar.gz
    wget ftp://ver22_sp:4pgrade@ftp.exlibris.co.il/ALEPH-ELIB-ServicePack-1-2123.tar.gz
    5. Extract the tar files:
    tar -zxvf ALEPH-ELIB-ServicePack-1-2123.tar.gz
    tar ?€“zxvf ALEPH-ELIB-ServicePack-1-2123-Bin-Linux.tar.gz
    6. Install Service Pack by running:
    ./sp.install -binary - step 1

    Category: Installation & Upgrades (500) - ALEPH

    Subject: Service Pack (500) - ALEPH


    • Article last edited: 1/26/2015