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    Clickatell SMS: no text message received; delivery failed due to routing error

    • Article Type: General
    • Product: Aleph
    • Product Version: 20

    Problem Symptoms:
    Trying to configure the ams proxy for provider Clickatell, using the instructions in the document "Configuring SMS from Aleph using provide Clickatell", the institution was added as described, with real account information.
    When testing as described in Step 4, the output indicates the request was successful, but no text message is received.
    The error report on the Clickatell account page shows that the the Clickatell server received the message, but delivery failed due to a "routing error".
    Checking with Clickatell tech support, the URL needs to have a "from=" and "MO=" parameter, which seems to be missing from the aleph ams proxy url. (See example in Additional Information below.)

    Cause:
    Missing ProviderMo and ProviderFrom parameters

    Resolution:
    As discussed in http://customercenter/DocumentationCenter/Ex Libris Documentation/Primo/OLH_4_9_1/Technical_Guide/SMS_Messages09.17.4.html , the <ProviderMo> and <ProviderFrom> parameters are required....

    *ProviderMo ?€“ Enter 1 (true) to enable two-way messaging for mobile originations.

    *ProviderFrom ?€“ Enter the mobile number assigned to the Clickatell account. This parameter is required to allow messages to be sent from your USA long code (which is required to send messages to the USA).
    A U.S. number should be preceded by "1". Example: 18472275555.

    Additional Information

    Sample URL (without the "from=" and "MO=" parameters) from the jboss server log: http://api.clickatell.com/http/sendmsg? user=umichlib_test&password=xxxxxxxxx&api_id=3534155&to=15173920656&text=test