Skip to main content
ExLibris
  • Subscribe by RSS
  • Ex Libris Knowledge Center

    Dependent module /usr/lib/libcrypto.a(libcrypto.so.0) could not be loaded

    • Article Type: General
    • Product: Aleph
    • Product Version: 20

    Description:
    In trying to install the new JBoss, I got to the util sp/6 step: Download third-party products update. When I press Enter


    *********************************************
    Make sure you have a working wget in your path
    *********************************************

    Downloading latest version of third party scripts to download dir
    exec(): 0509-036 Cannot load program wget because of the following errors:
    0509-150 Dependent module /usr/lib/libcrypto.a(libcrypto.so.0) could not be loaded.
    0509-152 Member libcrypto.so.0 is not found in archive
    Could not find the download script
    Operation aborted
    Press any key to continue

    It's clear that the server does *not* have a working wget. (The util_sp_06 proc issues this command:

    wget $WGET_OPTIONS -N "ftp://${FTPUSER}:${FTPPASS}@${PFTPSERVER}/${FTPSCRIPTSDIR}/*" )

    Resolution:
    This was resolved by getting a new "wget" from the Ex Libris ftp server:

    ftp://xxxxxx:Pr6gue@ftp.exlibris-usa.com/global.new/AIX.powerpc/util.AIX.powerpc.tar.gz

     

    [Contact Ex Libris Support for the actual command with the password (xxxxxx).  It's in an Internal Note.]

    then extracting under /exlibris/product .


    • Article last edited: 10/8/2013