Item arrival date changed to "--------" after item has been checked in
- Product: Aleph
- Product Version: 20, 21, 22, 23
- Relevant for Installation Type: Dedicated-Direct, Direct, Local, Total Care
Description
We are observing that the arrival date is deleted (changed to '--------') after an item is arrived and scanned to its location.
A second symptom is that the item also changes back to color red.
Resolution
Doing "global_grep 'TO Z30-ARRIVAL-DATE'" on the source of all the programs, we don't see
where this could be happening. (There are some batch jobs which initialize or update the
z30_arrival_date, but it wouldn't seem that you'd be running any of these once the item has
been received.)
Diagnosis:
1. Look at the current z30 record to confirm that the z30_arrival_date is currently blank.
2. Look at the value of the z30h_arrival_date in each of the item's z30h history records,
working back from the most recent to the oldest.
3. Send Ex Libris Support the z30h_arrival_date, Z30H_H_DATE, Z30H_H_HOUR, Z30H_REASON, and
Z30H_H_CATALOGER fields from each of the z30h records for this item.
See specific example in Additional Information.
In this particular case, the conclusion was: We are investigating right now, but we believe
one of our customizations is causing this.
Additional Information
A specific example:
We see this for item barcode 188880012648:
On 2016-01-22, the z30_arrival_date was zero and the item process status was changed by
cataloger XXXXX. Though it's not tracked as a history reason, it must be that the
z30_arrival date was changed to 2016-01-22 at this time too.
Then, on 2016-01-26, all of the following fields were changed (by YYYYYY): Location2,
Inventory Check, Location Type, Locat. And we see, from the z30h_arrival_date and the
current z30_arrival_date value of 00000000, that the z30_arrival_date, which had been set to
"2016-01-22" (on 2016-01-22), was then changed to zero.
We assume that it was not the cataloger's intention to zero out the arrival date.
Try to reproduce this -- take a different item, arrive it, and then make the same
changes and see if the arrival date is changed to zero.
If you are not able to reproduce it, it *is* possible to type over the arrival date and
change it to 00/00/0000. If you feel that this is not what happened, then we may need to add
some diagnostics to the program to check further.
- Article last edited: 15-May-2016