Skip to main content
ExLibris
  • Subscribe by RSS
  • Ex Libris Knowledge Center

    Loan incorrectly matches 1-character barcode to item lacking this value as barcode

    • Article Type: General
    • Product: Aleph
    • Product Version: 20

    Problem Symptoms:
    When a period, comma, 0, or 1 entered into the item barcode field in the GUI Circulation Loan screen, the loan occurs for a particular item which does *not* contain such a barcode and *does* have a correct (15-digit) barcode.

    Cause:
    ./xxx50/tab/tab100 has, either explicitly or by default, a setting of ITEM-BARCODE-OR-CALL-NO=Y. And incorrect 1-character values (due to scanner malfunction or operator error) can be matched on by blank or 1-character call numbers.

    Resolution:
    1. Specify ITEM-BARCODE-OR-CALL-NO=N in each ./xxx50/tab/tab100.

    2. Restart the pc_server(s).

    Additional Information

    From the tab100 header ITEM-BARCODE-OR-CALL-NO entry:
    ! Y = Item retrieval by call number is enabled
    ! N = Item retrieval by call number is disabled

    The same problem in *returning* items is described in the following Articles:

    Incorrect item checked in by ALEPH
    Wrong item is returned (and has in-transit slip produced) in GUI Circ

    Category: Circulation (500)


    • Article last edited: 5/12/2014