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    Locations in Primo: "Your content seems like it is taking a long time to load...."

     

    • Product: Aleph
    • Product Version: 20, 21, 22, 23
    • Relevant for Installation Type: Dedicated-Direct, Direct, Local, Total Care

     

    Problem Symptoms:
    When one clicks on "Locations" in Primo, it spins for a long time before returning and often gives the message "Your content seems like it is taking a long time to load. If you would like to try reloading it, click here.". 

    When it does complete, you can't expand the location information with the plus sign before each brief location entry. 

    Also, the availability statement in the brief display will show "updating" for a long time, i.e., waiting for ALEPH to respond with that information.

     

    Cause:
    Primo is not getting to the WEB Services Server (jboss). In this case the problem was that the jboss port (the dlf port)(1891) was not enabled in the firewall, but it could also be a problem with jboss not running on the Aleph server.

     

    Resolution:
    1. Open dlf port to the Primo Front End: Make sure the WEB Services Server (jboss) port is enabled in the firewall. (This port is usually 1891, but may, in some cases, be 1892, 1893, etc.) Its value can be seen as the "http.port" in the $alephe_root/jboss_conf/global.properties file. And

    2. Make sure that jboss is running: Article "How can I tell if jboss is running?"

     


    • Article last edited: 26-Jun-2016
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