Skip to main content
ExLibris
  • Subscribe by RSS
  • Ex Libris Knowledge Center

    Missing entries in circulation log in GUI client for some patron

    • Article Type: General
    • Product: Aleph
    • Product Version: 20

    Problem Symptoms:
    * Circulation log for some patrons does not display all recent activities in the GUI client.
    * Manually added entries do not show for this patron
    * SQL search of the database shows that the entries are correctly created

    Cause:
    Number of log entries is exceeding the number of displayable information

    Resolution:
    Delete old entries of circulation log with the help of Service "Circulation Logger Cleanup (cir-78)" to reduce the total number of log entries.

    Additional Information

    from the help file of this service:
    Circulation Logger Clean Up (cir-78)
    This service cleans up the circulation logger. All log events that are older than the input date will be deleted, if the transaction that they belong to is closed. This means that loan related events will be deleted only if the loan has been returned or deleted. Cash related events will be deleted only if the transaction has been fully paid. Requests refusal events will be deleted, as they are final events.

    Category: Circulation (500)


    • Article last edited: 10/8/2013