Skip to main content
ExLibris
  • Subscribe by RSS
  • Ex Libris Knowledge Center

    Unable to find global patron information": blank entered in in front of barcode

    • Article Type: General
    • Product: Aleph
    • Product Version: 18.01

    Problem Symptoms:
    * Newly created patron record cannot be found
    * Search results in error message C0463 21 "Unable to find Global Patron Information"
    * When search by patron name or patron ID the record appears in the listing, but when selected, the error "Remote Service Error (c0463 21): Unable to find global patron information." is displayed

    Cause:
    The patron barcode was entered with a preceding space

    Resolution:
    * Create a new patron record without blank in the barcode

    Additional Information

    The following SQL shows that the problem is that the barcode was entered in with a preceding space
    ABC50@ALEPH1> select * from z308 where z308_id = 'ID25259';
    **** Hit return to continue ****

    Z308_REC_KEY Z308_VERIFICATION Z3 Z308_ID Z3 Z
    --------------------------- ---------------------------------------- -- ------------ -- -
    00ID25259 ABC50 d8fa5148d1d14929c1b14909c19149e9c17149c9 00 ID25259 AC H
    01 111100000000036597 ABC50 caeb4253caca4232caaa4212ca8a41f7ca634ccc 00 ID25259 AC H

    Category: Circulation (500)

    Subject: Patrons


    • Article last edited: 10/8/2013