localhost_access_log files not being written to jlog directory
- Product: Aleph
- Product Version: 20, 21
- Relevant for Installation Type: Dedicated-Direct, Direct, Local, Total Care
Problem Symptoms:
localhost_access_log files are not being written to the /exlibris/aleph/a2n_n/ng/aleph/home/system/thirdparty/openserver/server/default/log/ directory (the "jlog" directory) .
The jlog directory has server.log.xxxx files but no localhost_access_log.yyyy-mm-dd files.
Cause:
JBoss was upgraded, and a default change was made to the /exlibris/aleph/a2n_n/ng/aleph/home/system/thirdparty/openserver/server/default/deploy/jbossweb.sar/server.xml file to turn this off.
Resolution:
1. Enter the command "jdeploy" to get to the deploy directory:
> jdeploy
> cd jbossweb.sar
2. Save the existing server.xml file:
> cp -p server.xml server.xml.beforechange
3. Edit the server.xml file:
> vi server.xml
Uncomment the "org.apache.catalina.valves.AccessLogValve" line:
<!-- Access logger -->
<!-- <--- delete this begin-comment line
<Valve className="org.apache.catalina.valves.AccessLogValve"
prefix="localhost_access_log." suffix=".log"
pattern="common" directory="${jboss.server.log.dir}"
resolveHosts="false" />
--> <--- delete this end-comment line
4. Restart jboss.
- Article last edited: 02-Mar-2016