Skip to main content
ExLibris
  • Subscribe by RSS
  • Ex Libris Knowledge Center

    Apache not loading, syntax error mod-jk file missing

    • Product: All products running Apache
    • Product Version: Apache 2.2.31 and up
    • Relevant for Installation Type: Local

    Symptoms

    After updating third party products to the latest version, Apache will not load with the following errors:

     

    • httpd: Syntax error on line 16 of /exlibris/primo/p4_1/primoe/apache/conf/httpd.conf:
    • Cannot load /exlibris/primo/p4_1/product/local/apache/modules/mod_jk.so into server: /exlibris/primo/p4_1/product/local/apache/modules/mod_jk.so: cannot open shared object file: No such file or directory

     

    Workaround

    The apache will not load since the mod-jk module has been omitted from the latest version of apache. This will be fixed for future releases.

     

    In the meantime please use the following workaround:

     

     

    1. log into the relevant server via ssh.

    2. Run the following:

    ls -d  /exlibris/product/http*
    

    This will list all the apache versions that reside on the server.

    3. If an older version of apache exists, copy over the mod-jk module from the latest version prior to the current one. i.e.:

    cp -p /exlibris/product/httpd-2.2.15/modules/mod_jk.so /exlibris/product/httpd-2.2.31/modules/
    

    If only only the latest version of apache shows up please download the <<attached file>> and place it in

    /exlibris/product/httpd-2.2.31/modules/
    

    4. Restart apache.