Skip to main content
  • Subscribe by RSS
  • Ex Libris Knowledge Center

    Upgrade FL version does not use correct DROID plugin

    • Article Type: General
    • Product: Rosetta

    Problem Symptoms:
    We found there are missing formats in the format library.
    After upgrading to higher FL version, ingests fail. Only coping an older version of the FFDroidIdentifier.jar solved it

    Wrong version of the jar
    Only if FFDroidIdentifier under the bundle directory has a higher version than the jar under the deploy directory it will be installed.

    1. From the Plugin Management screen (Advanced Configuration > Plug-In Management > Plug-In Management), delete the FFDroidIdentifier plugin instance(s).
    2. Remove the FFDroidIdentifier.jar from the /operational_shared/plugins/bundled and from /operational_shared/plugins/bundled/deploy/ directories.
    3. Install latest FL version (Home > Preservation > Format Library > Manage Format Library Version).

    Additional Information

    * If there were more than one plugin instance of FFDroidIdentifier plugin (with different plugin names), and they were all in use by different material flows, there might be a need to recreate the additional instances manually (in the Plugin Management screen) after step 3 above, to allow all existing flows to work. The default one is recreated automatically with the Format Library re-installation.

    * In some environments a FFDroidIdentifier-1.1.jar file also exist in the directories mentioned in step 2. It can be removed, but this is not necessary.

    Category: Rosetta -

    • Article last edited: 12/25/2014