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    CAT: "Unable to save record" after replacing auth

    • Article Type: General
    • Product: Voyager
    • Product Version: 8.1.1

    Problem Symptoms:
    * Sometimes saving a new record results in ?Unable to save record.?
    * Problem persists until client is restarted.

    Cause:
    This behavior is the result of issue 16384-21857.

    Resolution:
    Issue 16384-21857 is resolved in Voyager 8.2.1.

    If you are on Voyager 8.2.1 and are experiencing symptoms of this issue, please open a Support Incident to request the fix for this issue.

    Additional Information

    Replication steps:
    1. In SysAdmin > Cataloging > Authority Duplicate Detection Profiles, create or find a profile with the following values:
    a. Duplicate handling = Replace
    b. Cancellation = <any value>
    c. Duplicate Warn / Replace = 100
    d. Field Definitions tab: select indexes that will match (A10A, A35A, ATID, etc.). with Field Weight = 100
    2. Add the profile to the Cataloging Policy Definition.
    3. In Cataloging, set the Authority Duplicate Detection profile in Options > Preferences.
    4. Import an Authority record from attached file.
    5. Save to DB.
    6. Import the same record again.
    7. The record will replace the record in the database.
    8. Now import a bib record that will not match/replace an existing bib but be added as a new record.
    9. Receive ?Unable to save record.?
    10. New records cannot be added until client closed & reopened.
    11. After reopening client, same record can be imported and saved to database.
    12. Problem recurs the next time you replace an authority record in the client.

    Workaround: Log out of client and log in again.

    Other information: Problem does not occur if bib record has duplicate in database.

    Category: Cataloging


    • Article last edited: 10/8/2013