Skip to main content
ExLibris
Ex Libris Knowledge Center

UTIL: Cannot run keyword regen: "An index regen is currently running for xxxdb"

Symptoms

  • Running a keyword index regen using the UTIL menu results in error: "An index regen is currently running for <xxxdb>" (where xxxdb is the Voyager Database Instance)
  • Cause

This issue is due to a previous regen not properly completing, resulting in the process id file for the previous regen being left in place, causing the subsequent regen to infer that the previous regen has not been completed.

Resolution

Delete the regen pid file "regen_running" from the previous regen:

 

  1. Locate the file for the previous regen. This file will be located at /m1/voyager/utility/<Voyager version #>/XXXdb/regen_running
  2. Ensure that the regen is not running by running: "ps -f -p $(cat regen_running)"
  3. If no regen is running delete the file ("rm regen_running")
  4. Rerun the regen using util.
  • Was this article helpful?