Skip to main content
ExLibris
  • Subscribe by RSS
  • Ex Libris Knowledge Center

    检索资源

    可译的
    通过检索资源(资源 > 编目 > 检索资源),您可以检索本地资源例如机构区,网络区和共享区,以及任何由Ex Libris数据服务支持的外部数据库。
    Alma通过对位于外部数据库中的记录的搜索和导入直接集成到元数据编辑器中来支持套录编目。 可以使用Ex Libris Data Services支持的并由您的机构启用的任何搜索目标/数据库进行资源检索。
    如果您的机构是合作网络的成员,则可用的检索资源列表由 合作网络中的外部检索系统 部分中描述的配置和设置决定。
    外部数据库可以在元数据编辑器界面中进行搜索,并且搜索结果中显示的记录可以从搜索结果屏幕直接导入到Alma中。 此外,配置后,Alma可以搜索您的仓储中与导入的记录匹配的记录,将变体记录合并到单个记录中,或将现有记录与导入的记录叠加。
    要定义使用的正确配置文件,您必须在 serial_match_profile以及non_serial_match_profile 参数值列(配置>资源>通用>其他设置)包含相应的文件密匙。 有关这些文件密钥的详细信息,见配置其它设置中的表格。
    要配置外部检索包含导入、合并和覆盖,见配置外部资源检索配置外部检索资源。 在定义/配置了需要检索的外部资源后,您可以创建检索配置文件定义这些资源用于检索。 要创建检索配置文件,见配置检索配置文件。 请注意,在检索配置文件中,您可以同时设置外部和本地资源用于检索。
    资源检索使您可以检索外部数据库并在导入到仓储之前查看并选择相关记录。
    除了元数据编辑器之外,Alma菜单(资源>编目>检索资源)还提供检索资源功能。
    当您在元数据编辑器中选择记录并执行资源检索时,将自动激活拆分编辑器选项,并使用当前记录中的信息自动填充相关搜索字段。

    在元数据编辑器中使用检索资源

    本节介绍在元数据编辑器中使用检索资源。
    要检索本地/外部资源:
    1. 打开检索资源(资源管理>资源>编目>检索资源)。
      MD_Editor_Search_External_Resources_Page_NewUI_04_TC.png
      检索资源页面
      您也可以使用元数据编辑器(工具 > 检索资源)中的选项检索资源。 当在元数据编辑器中打开了记录时,检索字段自动填充来自打开的记录的检索词,如下例所示。
      MD_Editor_Search_External_Resources_Page_with_Draft_Record_Open_NewUI_04_TC.png
      元数据编辑器检索资源页面
      请注意检索资源选项在元数据编辑器中打开的记录链接到共享区时不可选。 如果选择套录编目文件 > 套录编目),链接断开;且您可以在元数据编辑器中选择检索资源选项(工具 > 检索资源)。
    2. 检索编目配置文件 下拉列表中选择预定义的检索配置文件。 有关定义检索配置文件的详细信息,见配置检索配置文件
    3. 根据字段名称在可用字段中输入检索值,并为输入的字段选择所需的输入期望值。 您可以从以下选项中选择输入期望值:
      • 包含短语
      • 包含关键词
      • 出版年字段必须包含四位数字。
      • 值为已屏蔽标签(题名) 将自动添加为检索条件的一部分。
    4. 选择是否希望每个搜索字段之间都有和/或
    5. 选择检索。 见以下检索结果示例。 如果想要修改检索标准,选择重定义检索
      Search_Resources_Results_06.png
      检索资源结果页面 - 示例1
      External_Search_Results_Page-Example_2_04.png
      检索资源结果页面 - 示例2
      检索资源的结果显示选项卡的多少取决于您的检索配置(见配置检索配置文件)。 检索配置也决定选项卡的显示顺序。 请注意,您可以让检索结果显示本地资源和外部资源。 在示例1中,WorldCat配置文件也指定了本地机构区和共享区为检索处理的部分。
      仅在OCLC(WorldCat)记录中显示 预约人 指示。
    6. 要在检索资源结果页面查看单册的记录详情,点击单册题名或点击题名下的查看;然后点击回到结果返回检索资源结果页面。 请注意,对于本地资源,您可以选择编辑操作。
    7. 要在检索资源结果页面导入外部来源的单册书目记录,点击题名下的导入链接;或者如果您正在查看记录详情(步骤6),点击导入。 书目记录导入到元数据编辑器的草稿文件夹中(且在其旁边有一个草稿图标),您可以像其他记录一样使用它。 这包含可以创建订单行(见要创建订单行)。
      导入记录(或执行覆盖或合并)时,初始系统版本的记录更新为外部目标中的记录版本。要配置导入,覆盖或合并的外部检索,见配置外部检索资源

    在元数据编辑器中使用检索资源并使用KERIS

    使用检索资源,您可以访问以下KERIS选项(当您的系统中已配置时;见配置外部检索资源):
    • KERIS (Korea Education and Research Information Service)
    • KERIS (KORMARC)
    Search_External_Resources_in_the_MD_Editor_04_TC.png
    在元数据编辑器中检索资源
    这些资源在KORMARC记录格式和MARC 21记录格式中含有更多记录。 但是,在使用这些外部检索资源时,结果中KORMARC格式和MARC 21格式会同时出现。 当使用检索资源导入记录时,使用以下方法确定导入记录时使用的记录格式:
    • 默认实施
      当您使用配置为KERIS KORMARC的配置文件时,使用检索资源从KERIS导入记录,并且KERIS资源包含KORMARC记录格式和MARC 21记录格式的记录时,KERIS KORMARC记录存储在 KORMARC书目文件夹中,如下所示。
      使用KERIS KORMARC时导入KORMARC格式的记录
      当您使用KERIS配置文件导入KERIS记录时,记录将存储在MARC 21书目文件夹中, 因为使用KERIS配置文件向Alma指示正在导入MARC 21记录格式记录。
    • 定制客户参数(由Ex Libris设置)
      使用此方法,Alma在LDR第十位的内容指定记录格式。 MARC 21中由u2标识,且KORMARC中由ck标识。 您的检索结果会带有MARC 21和KORMARC标识。 指定的记录格式会在导入记录时使用。
      MARC_21_KERIS_Record_Format_in_External_Search_Results_08.png
      在检索资源结果中标识MARC 21和KORMARC记录格式

    通过元数据编辑器检索资源导入记录并查看UNIMARC交叉审核

    使用检索资源导入记录时,见以下查看UNIMARC交叉审核步骤。
    要配置导入、覆盖或合并的外部检索,见配置外部资源检索
    要在检索资源/套录编目时查看UNIMARC交叉审核:
    1. 打开元数据编辑器(资源 >编目> 打开元数据编辑器)。
    2. 创建新UNIMARC记录(文件 > 新建 > UNIMARC书目)。
    3. 打开资源检索工具(工具 > 检索资源)。
    4. 在MARC 21数据库(如OCLC)中完成资源检索。
    5. 检索结果显示时,点击合并预览链接您想要的书目记录。
      Merge_Preview_Link_02_TC.png
      合并预览链接
    6. 查看预览内容中的相应字段以确认预览记录已转换为UNIMARC格式。 例如,700字段应显示作者信息。
      UNIMARC_700_Field_Author_Information_04.png
      UNIMARC 700字段示例
    7. 点击复制与合并链接并完成对记录的编目。
    • Was this article helpful?