Skip to main content
ExLibris

Knowledge Assistant

BETA
 
  • Subscribe by RSS
  • Back
    Primo

     

    Ex Libris Knowledge Center
    1. Search site
      Go back to previous article
      1. Sign in
        • Sign in
        • Forgot password
    1. Home
    2. Primo
    3. Knowledge Articles
    4. Backup Package: Primo software backup (p4): error message "tar: [...] File removed before we read it"

    Backup Package: Primo software backup (p4): error message "tar: [...] File removed before we read it"

    1. Last updated
    2. Save as PDF
    3. Share
      1. Share
      2. Tweet
      3. Share
    No headers
    • Article Type: General
    • Product: Primo

    Problem Symptoms:
    The following error messages appear in the log file of the Primo software backup p4 (/exlibris/backup/logs/prd_software_p4_Detail_<date>_<time>.log):

    tar: exlibris/primo/p4_1/primoe/apache/htdocs/exlibris/primo/p4_2/tmp: File removed before we read it
    tar: exlibris/primo/p4_1/primoe/apache/htdocs/exlibris/primo/p4_2/log: File removed before we read it
    [...]

    Cause:
    The Primo software backup (p4) uses the command tar with the option -h (synonym for: --dereference). This option means: follow symlinks; archive and dump the files they point to.

    The file mentioned in the error message "tar: [...] file changed as we read it" is a stale symbolic link: a link pointing to a file that does not exist.

    The error message warns that a file may be missing and therefore the backup of the Primo software may be incomplete.

    Resolution:
    (1)
    Display the stale symbolic links and their targets in the directory tree /exlibris/primo/p4_1 by entering the following command as UNIX user primo:

    $ find /exlibris/primo/p4_1 -type l | perl -nle '-e || print;' | xargs -r ls -ld

    lrwxrwxrwx 1 primo exlibris 68 Jan 14 2014 /exlibris/primo/p4_1/primoe/apache.v4/htdocs/PDSAleph.css -> /exlibris/primo/p4_2/pds/html_form/calling_system-aleph/PDSAleph.css
    lrwxrwxrwx 1 primo exlibris 74 Jan 14 2014 /exlibris/primo/p4_1/primoe/apache.v4/htdocs/PDSDigitool.css -> /exlibris/primo/p4_2/pds/html_form/calling_system-digitool/PDSDigitool.css
    [...]


    (2)
    Check if any of the target files reported in Step 1 is relevant for the operation of Primo. If you find that a relevant file is missing please restore it.


    (3)
    Delete all stale symbolic links that point to irrelevant target files.

    If you find that all target file reported in Step 1 are irrelevant, you can delete their symbolic links in one go by entering the following command as UNIX user primo:

    $ find /exlibris/primo/p4_1 -type l | perl -nle '-e || print;' | xargs -r rm


    (4)
    Start the Primo software backup (p4) again.


    • Article last edited: 12/10/2014
    View article in the Exlibris Knowledge Center
    1. Back to top
      • Backup Package: Primo software backup (p4): error message "tar: [...] file changed as we read it"
      • Backurl for reset password link in Primo is not working?
    • Was this article helpful?

    Recommended articles

    1. Article type
      Topic
      Community Content Type
      How To
      Content Type
      Knowledge Article
      Language
      English
      Product
      Primo
    2. Tags
      1. contype:kba
      2. Prod:Primo
      3. Type:General
    1. © Copyright 2025 Ex Libris Knowledge Center
    2. Powered by CXone Expert ®
    • Term of Use
    • Privacy Policy
    • Contact Us
    2025 Ex Libris. All rights reserved