Skip to main content
ExLibris
  • Subscribe by RSS
  • Ex Libris Knowledge Center

    FE does not start correctly after November 2016 Service Pack

    • Product: Primo
    • Product Version: November 2016
    • Relevant for Installation Type: Dedicated-Direct, Local

     

    Symptoms

    1. Cannot access the Primo Front End after installing Primo November 2016 Service Pack
      It gives 404 error with these messages: type Status report message /primo_library/libweb/action/search.do description The requested resource is not available. 
    2. Deploy All fails
    3. fe_log library_server.log has:
    2016-12-10 11:01:56,364 ERROR [t-localhost-startStop-1] [c-ContextLoader] [O -] - Context initialization failed
    ...
    Caused by: java.io.FileNotFoundException: c:/exlibris/primo/3.0/security/primo1.keystore (No such file or directory)
    ...
    SEVERE: Context [/primo_library/libweb] startup failed due to previous errors

     

    Resolution

    1. Edit the configuration in 

        BO > General Configuration > Installation 

     

    javax.net.ssl.keyStore c:/exlibris/primo/3.0/security/primo1.keystore
    javax.net.ssl.keyStorePassword primo3 
    javax.net.ssl.trustStore c:/exlibris/primo/3.0/security/primo1.keystore
    javax.net.ssl.trustStorePassword primo3



     They should be empty:

     

    javax.net.ssl.keyStore  
    javax.net.ssl.keyStorePassword  
    javax.net.ssl.trustStore  
    javax.net.ssl.trustStorePassword  

     

     

     

    1. Save the changes (no need to deploy)
       
    2. Restart the FE.
       
    3. Run Deploy All to finish installation.

     

     


    • Article last edited: 22-Dec-2016