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    No e-mail Sent from Details Tab Send To or e-Shelf

    • Article Type: General
    • Product: Primo
    • Product Version: 4

    Problem Symptoms:
    * Email not sent when using Details tab "Send to" or e-Shelf.
    * Error message appears in library_server.log file (for details, see Additional information below)

    Cause:
    Missing domain name the Back Office General Configuration Wizard and/or Code Tables.

    Resolution:
    1. In the Back Office, check if missing domain name definition <xxxxx@DomainName> in
    a. General Configuration Wizard > E-mail and SMS Configuration > E-Mail Sender
    b. Code Tables > {LocalInstitution} > Front End > Send Email and Sms > default.email.form
    c. Code Tables > {LocalInstitution} > Front End > Send Email and Sms > default.alert.from

    2. If missing, add domain name

    3. Save and deploy relevant section

    Additional Information

    fe_log > library_server.log file error message:

    ERROR [t-http-0.0.0.0-1701-5] [c-EmailAction] - Failed to send e-mail:
    org.springframework.mail.MailSendException: Failed messages: com.sun.mail.smtp.SMTPSendFailedException: 553 5.5.4 <xxxxxx>... Domain name required for sender address "xxxxx"
    ; message exceptions (1) are:
    Failed message 1: com.sun.mail.smtp.SMTPSendFailedException: 553 5.5.4 <xxxxx>... Domain name required for sender address xxxxx


    • Article last edited: 11/20/2013