Primo Service Pack failure due to no free space
- Article Type: General
- Product: Primo
- Product Version: April 2015
- Relevant for Installation Type: Local;
Problem Symptoms
- The Service Pack process seems to be taking a long time (e.g. more than one hour)
- The Service Pack process was cancelled (e.g. the command `ps -ef | grep sp.install | grep -v grep` produces no results)
- The file space completely filled up (e.g. the command `du -sh /exlibris` file system shows 100% utilization)
- The $primo_install_service_pack/sp.4.9.1/logs/sp.log file contains the message "The apply process failed. Please contact exlibris support."
- The $primo_install_service_pack/sp.4.9.1/logs/apply_patch_home.log.* file contains:
error-No space left on device
BUILD FAILED
/exlibris/primo/p4_1/service_pack/sp.4.9.1/patchtool/bin/patchtool.xml:145: java.lang.RuntimeException: java.io.IOException: No space left on device
Cause
This error will occur if there is not enough free file space to apply the Service Pack
Resolution
1. Create additional free space in /exlibris by moving, compressing, or removing files (see Additional Information for recommended articles
2. Open a case with ExLibris Support to analyze and clean up the failed Service Pack
Additional Information
The Primo April 2015 release is sometimes referred to as SP 4.9.1.
*Recommended Articles For Creating Free Space
Category: Installation, Upgrade, Removal