opensaml::FatalProfileException when using PDS with Shibboleth
- Article Type: General
- Product: Primo
- Product Version: April 2015
- Relevant for Installation Type: Dedicated-Direct; Direct; Local; Total Care
Problem Symptoms
- PDS uses Shibboleth for Patron Authentication
- Clearing the browser cache provides a temporary fix
- Attempting to login results in the following error:
opensaml::FatalProfileException
The system encountered an error at <date & time>
To report this problem, please contact the site administrator at <e-mail address>
Please include the following message in any email:
opensaml::FatalProfileException at (https://<PDS_SERVER>/Shibboleth.sso/SAML2/POST)
SAML response reported an IdP error.
Error from identity provider:
Status: urn:oasis:names:tc:SAML:2.0:status:Responder
Cause
This error will occur if the local Shibboleth IdP (Identity Provider) returns the user to the PDS Shibboleth SP (Service Provider) with a failed authentication message.
Resolution
The problem is not with PDS but with the local Shibboleth IdP. Resolution requires reporting the problem to the administrator of the local Shibboleth IdP.
Category: PDS