Skip to main content
ExLibris
  • Subscribe by RSS
  • Ex Libris Knowledge Center

    After upgrade to RH 6.6: SunOne LDAP server can not be started

    • Article Type: General
    • Product: Aleph

    Problem Symptoms:
    After patching Red Hat OS to version 6.6 ARC stop working as the SunOne LDAP server can not be started anymore:

    ./start-slapd
    [22/Oct/2014:15:21:30 +0300] - ERROR<4112> - Bootstrap config - conn=-1 op=-1 msgId=-1 - Configuration error Plugin cn=Binary Syntax,cn=plugins,cn=config has an invalid signature -- NSS initialization failed

    Cause:
    Compatibility issues between SunOne LDAP server and RH 6.6
    Problematic package: nss-softokn-freebl-3.14.3

    Resolution:
    Install ARC Service Pack (release date 02/2015):
    ARC 3.2
    ARC 4.1

    Additional Information

    Customers already upgraded to RH 6.6 and are not able to install the latest Service Pack, could temporarily downgrade the specific (problematic) package:
    yum downgrade nss-softokn-freebl-3.14.3
    This will leave the OS version 6.6 only with the specific package from 6.5


    • Article last edited: 2/11/2015