Skip to main content
ExLibris
  • Subscribe by RSS
  • Ex Libris Knowledge Center

    Apache: what version(s) does Ex Libris supply/support?

     

    • Product: Aleph
    • Product Version: 20
    • Relevant for Installation Type: Dedicated-Direct, Direct, Local, Total Care

     

    Description:
    What version of Apache is included with Aleph 20.2.6 or 20.2.7? For Aleph customers, is it recommended to only use the version of Apache provided by Ex Libris? Does Ex Libris supply documentation/guidelines for upgrade?

     

    Resolution:
    Aleph supports a range of Apache versions. 2.2.15 -> 2.2.22 can be used with Aleph v20. 

    Customers get the apache appropriate for their version of Aleph in the Aleph Installation Kit (AIK). If you are installing Aleph without using the AIK, you should install the version of apache which the AIK is installing. 

    There are occasions where, in the life of particular version, Ex Libris tests and approves a newer version of Apache for use with that Aleph version. One example is KB 31801 (version 18) and KB 30562 (version 20) in which Ex Libris announced: “Aleph now supports Apache version 2.2.15.”

    The version 20 and 21 AIK's are installing httpd 2.2.22. This is what version 20 and 21 customers should use until Ex Libris announces support of a higher version.

    KB 32185 describes the procedure for upgrading to Apache version 2.2 on an Aleph 20 machine.

     

     


    • Article last edited: 12-Mar-2016