"Errors detected in required email(s) ..." running print daemon on multiple PC's
- Article Type: General
- Product: Aleph
- Product Version: 22
Problem Symptoms:
Multiple workstations receive an error message, "Errors detected in required email(s). Please refer to errors node in the Print History." The e-mail addresses found in these error messages *do* work correctly.
Also, the list of print Errors/patrons with errors in one client is totally different from the list of print errors/patrons with errors on another client.
Also, reports that patrons are not receiving e-mails to pick up items them have placed on hold or requested from offsite. The circulation log claims that the hold letters were sent, but the e-mails are never actually sent.
Cause:
Running the print daemon on multiple PC's. This is a problem because if multiple print daemons are processing the same notice at the same time the notice could be printed/emailed twice.
When the print daemon finishes its processing it moves the files it has processed from the ./xxx50/print directory to an ./xxx50/print/save-yyyy-mm-dd directory. Once this is complete, the files will not be processed again by this or any other print daemon.
Thus, if a print daemon completed its processing and was stopped (using the GUI Print Daemon "Deactivate" button), and the print daemon on another PC was started, that would not be a problem. But two print daemons running at the same time is a problem.
Resolution:
Run the print daemon on just a single PC.
See Additional Information below for starting/stopping the print daemon.
Additional Information
See also, Article 000022643 {Error message "Errors detected in required email(s) ..." while printing letters from the Task Manager}.
See also, Article 000024710 ("How to start/stop the print daemon")
Category: Circulation (500)
- Article last edited: 9/29/2014