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    GUI Acq: "Failed to read reply"; pc_server log: "Execution error .../get_buf_z71.gnt'"

     

    • Product: Aleph
    • Product Version: 20, 21, 22, 23
    • Relevant for Installation Type: Dedicated-Direct, Direct, Local, Total Care

     

    Problem Symptoms: 
    After upgrading to version 21 (or 22), the following error message occurs repeatedly in the pc_server log file: 

    Execution error : file '/exlibris/aleph/a21_1/aleph/exe/get_buf_z71.gnt' 
    error code: 114, pc=0, call=1, seg=0 
    114 Attempt to access item beyond bounds of memory (Signal 11) 

    (but the transaction succeeds on subsequent tries). 

    Display's added to the get_buf_z71 program showed: "BUF-71-NO-LINES= 538976288" (538,976,288) -- despite the fact that there are only 8,782,327 xxx50 z71 ("Order and Subscription Log") records in total. 

     

    Cause: 
    A z71 key with an excessive number of records. See Additional information below. 

     

    Resolution: 
    1. Delete all z71 records with the z71_rec_key "I00000000000000". (The ADM/order number 0000000000000 is an incorrect, non-existent key.) 

    2. Implement v21 Service Pack 2579 (21.1.5) or v22 Service Pack 35 (22.0.1).


    Additional Information    
    The following SQL (to check for z71 record keys with unusually large numbers of occurrences) retrieved 1 record key:

    select substr(Z71_REC_KEY,1,15) as "rec_key", count as "no_recs" from z71
    group by substr(Z71_REC_KEY,1,15) having count > 64000 order by count desc;

    REC_KEY ........................ NO_RECS
    --------------------------------------------- ----------
    I00000000000000 104006

     

     


    • Article last edited: 12-Mar-2016