Skip to main content
ExLibris
  • Subscribe by RSS
  • Ex Libris Knowledge Center

    Table changes are not being recognized by NCIP funtionailty

     

    • Product: Aleph
    • Product Version: 20, 21, 22, 23
    • Relevant for Installation Type: Dedicated-Direct, Direct, Local, Total Care

     

    Problem Symptoms:
    After making table changes to support NCIP operation and restarting the ncip_server, the changes are not being reflected in NCIP functionality.

     

    Cause:
    The NCIP protocol allows for multiple transport methods ג€“ HTTP, HTTPS, or direct connect over TCP/IP. When using direct connect over TCP/IP, then the ncip_server handles messaging. But if the external partner is using HTTP or HTTPS to send NCIP messages, these are being handled by the Aleph www_server. In this case, the www_server needs to be restarted in order to utilize table changes.

     

    Resolution:
    Restart the www_server.

     

     


    • Article last edited: 28-Feb-2016
    • Was this article helpful?