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    Transit slips created for items when non-alphanumeric characters are entered in Item Bar in GUI

     

    • Product: Aleph
    • Product Version: 20, 21, 22, 23
    • Relevant for Installation Type: Dedicated-Direct, Direct, Local, Total Care

     


    Problem Symptoms 

    When a comma (or other non-alphanumeric character - e.g., a semicolon), is entered into the Item Bar, and "Enter" is clicked, a valid item record is retrieved, and a transit slip is created erroneously. 


    Cause 

    A setting in the ADM library's tab directory on the UNIX server, combined with a zero entered in the z30_call_no_key of the records, results in a transit slip incorrectly being created. 


    Background/Replication 

    1. Log in to the UNIX server as user "aleph" and enter the following commands: 

    2. dlib xxx50 
    To enter the ADM library on the server. 

    3. dt 
    To change to the ADM library's "tab" directory. 

    4. view tab_filing_call_no 
    To open the file. 

    In this file, if this line appears: 
    0 L add_call_no_type 
    It means that the value in the call_number_type field (e.g., "0" above) as the first position of z30_call_no_key, plus one blank. 

    If a 0 was previously entered into the z30_call_no_key for a record without a call number, this results in: 

    02 z30_call_no_key .............0 0 

    instead of 

    02 z30_call_no_key .............0 

    Which confuses the system and a transit slip is generated. 


    Resolution 

    1. Log into the GUI Circulation module. 

    2. Under the Services menu, select Items > Advanced Update Item Records (manage-63). 

    3. There are three options with this service: 
    A. If there is a specific list of items to be corrected: enter the name of the file that contains Item record numbers previously retrieved by the "General Retrieval Form" and saved in a file in the $alephe_scratch directory. Leave the ADM Record Number field blank. 

    B. If only one item is to be corrected: enter a single ADM number in "ADM Record Number", and leave the Input File field blank. Substitutions will be made for all copies that are registered under the ADM number. 

    C. In order to change any instance of "0 0" without a specific list of items: leave both fields blank, in which case ALL ITEM RECORDS WITH "0 0" WILL BE CHANGED. 

    4. In the "Updated Items Output File" field and the "Rejected Items Output File" field, enter the filenames that these output files will have when they are created with this service. 

    5. From the first "Field to Update" dropdown menu, select "Item Call no. 1 type". 

    6. In the "From:" field below this, enter "0 0" (0<space>0). 

    7. In the "To:" field, enter "0". 

    8. Click "Submit" to start the process. 

    9. Once the process has completed, verify the output files are as expected, and verify the z30_call_no_key in the z30 record appears as "0". (See additional information for z30 checking). 

    10. To verify that no transit slip is created erroneously, enter a comma (or other non-alphanumeric character - e.g., a semicolon) in the Item Bar. A window will pop up with the following message: "Unable to find item."


    Additional Information    
    To verify z30_call_no_key:

    1. Login to UNIX server as "aleph" user and enter the following commands:

    2. dlib xxx50
    To access the xxx50 library.

    3. util f/4
    To "Display Oracle tables data".

    4. z30
    To view z30 records.

    5. k
    To enter a particular key (i.e., to search for a particular record).

    6. 1 (if searching by the z30-doc-number)
    or
    2 (if searching by the z30-barcode)

    7. Enter the z30-doc-number or z30-barcode (depending on step 6).

    8. Confirm that the line z30_call_no_key has a "0" and not "0 0".
     

     

     


    • Article last edited: 02-Mar-2016
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