Skip to main content
ExLibris
  • Subscribe by RSS
  • Ex Libris Knowledge Center

    Upgrade Express: "A_ERROR: The table znn does not exist in xxxnn"

    • Article Type: General
    • Product: Aleph
    • Product Version: 20

    Problem Symptoms:
    "A_ERROR: The table znn does not exist in xxxnn" message in a "3. upgrade express" step log.

    Cause:
    1. If the message appears for *all* of the znn Oracle tables, the install_utree step may have failed to load *any* local tables: the USMnn tables (created by the AIK) exist, but the XXXnn local tables do not. See Article 000036880 ("Upgrade Express: install_utree step fails to load *any* Oracle tables") (link below).

    2. If some Oracle tables are processed OK by Upgrade Express, but others are not, then either

    a) there was a problem with the export of the Oracle data for that particular library; or

    b) the library is defined (in its tab100) with DOC-TYPE-ADM=Y, when, in fact, the library is not an ADM library.

    Resolution:
    Cause 1: See Article 000036880.

    Cause 2a: Check the create_customer_data step for this particular library in the Source instance.

    Cause 2b: See Article 000041898 {"A_ERROR: table znnn does not exist in xxxnn (where xxxnn is pw_library/usr_lib")"} (Link below).

    Additional Information


    Article link:  Upgrade Express install_utree step loads no Oracle data; "dpdir Not Found"
    Article link:  A_ERROR: table znnn does not exist in xxxnn (where xxxnn is pw_library/usr_lib 

    Category: Installation & Upgrades (500)

    Subject: Upgrade Express (500)


    • Article last edited: 9/17/2014