Skip to main content
ExLibris
  • Subscribe by RSS
  • Ex Libris Knowledge Center

    V18 Service Pack 1117 error: "Critical error... ill_server_main didn't compile"

    • Article Type: General
    • Product: Aleph
    • Product Version: 18.01

    Description:
    I have tried to install v18 SP 1117 on our test server. It failed due to following errors and warnings. Please help. Thanks in advance

    ***************
    "aleph.c", line 848: warning: implicit function declaration: compress_gzlib
    "aleph.c", line 849: warning: implicit function declaration: compress_zlib
    "aleph.c", line 850: warning: implicit function declaration: uncompress_gzlib
    "aleph.c", line 851: warning: implicit function declaration: uncompress_zlib
    Critical error: /waleph/aleph/a18_1/aleph/exe/ill_server_main didn't compile
    Running uninstall...

    Resolution:
    The problem is environmental: the customer’s gcc is incorrect, i.e. it’s not from the “product”:

    >>which gcc
    /usr/local/bin/gcc

    And in the directory $aleph_product/bin, there is no complete installation of gcc.

    Please see KB 8192-6151, which is a similar case.

    This issue is still open and was escalated to Second line support for further analysis <2007-08-12 01:00:08>.


    • Article last edited: 10/8/2013
    //Feedback