Skip to main content
ExLibris

Knowledge Assistant

BETA
 
  • Subscribe by RSS
  • Back
    Aleph

     

    Ex Libris Knowledge Center
    1. Search site
      Go back to previous article
      1. Sign in
        • Sign in
        • Forgot password
    1. Home
    2. Aleph
    3. Knowledge Articles
    4. jboss errors starting aleph: "DEPLOYMENTS MISSING DEPENDENCIES"

    jboss errors starting aleph: "DEPLOYMENTS MISSING DEPENDENCIES"

    1. Last updated
    2. Save as PDF
    3. Share
      1. Share
      2. Tweet
      3. Share
    1. Additional Information
    • Article Type: General
    • Product: Aleph
    • Product Version: 20

    Problem Symptoms:
    jboss won't start. Errors in the alias= jlog server.log:

    DEPLOYMENTS MISSING DEPENDENCIES:
    Deployment "CachedConnectionManager" is missing the following
    dependencies:
    Dependency "TransactionManager" (should be in state "Configured", but is actually in state "Instantiated")
    Deployment "DefaultUserTransactionprovider" is missing the following
    dependencies:
    Dependency "<UNKNOWN DefaultUserTransactionprovider>" (should be in state "Described", but is actually in state "** UNRESOLVED Demands 'TransactionManager' **")
    <etc.>

    Cause:
    1. JBoss fails to start because Aleph 20 is set up to use a Java Runtime Environment whose version (1.5.0_22) doesn't match the version of JBoss (5.1.0). The following error message at the head of the JBoss log file server.log points to the cause of the problem:

    java.lang.UnsupportedClassVersionError: Bad version number in .class file

    The following symbolic link was making Aleph use Java version 1.5.0_22:

    /exlibris/aleph/a20_1/product/local/java ---> /exlibris/product/jdk1.5.0_22.i386

    2. These messages may indicate a problem with jboss accessing certain ports.
    * jboss_conf port settings need updating, and/or
    * port 189n (1891, 1893, etc.) needs to be opened to jboss.

    Resolution:
    1. Change setup to use a Java Virtual Machine whose version (1.6.0_21) matches JBoss 5.1.0: change the target directory of the symbolic link above as follows:

    /exlibris/aleph/a20_1/product/local/java ---> /exlibris/product/jdk1.6.0_20.i686

    2. Start JBossS (with util w/3/7/9) and verify that there are no error messages in the log file server.log.

    Additional Information

    In the case of cause #2, the messages could indicate a problem with jboss accessing certain ports.

    a. Correct settings in $alephe_root/jboss_conf/main.properties and ./global.properties.

    In ./main.properties change
    from:
    xservice.server.port=4991
    to:
    xservice.server.port=80

    And in ./global.properties change
    from:
    < jndi.port=289@_AL_SUB_PORT
    < rmi.port=389@_AL_SUB_PORT
    < rmi.object.port=399@_AL_SUB_PORT
    < webservice.port=489@_AL_SUB_PORT
    < debug.port=500@_AL_SUB_PORT
    < server.pool.port=689@_AL_SUB_PORT
    < ajp.port=789@_AL_SUB_PORT

    to:
    > jndi.port=2891
    > rmi.port=3891
    > rmi.object.port=3991
    > webservice.port=4891
    > debug.port=5001
    > server.pool.port=6891
    > ajp.port=7891

    * Do:

    >> jbin
    >> set_globals.sh

    as instructed in KB 16384-28513 ("Problems starting JBOSS in Aleph 18"),

    b. Open the 189n port to jboss.

    c. Start jboss with util w/3/7/9.

    Category: Upgrade


    • Article last edited: 10/8/2013
    View article in the Exlibris Knowledge Center
    1. Back to top
      • Jboss error message instead of data for large account of loans
      • jboss files updated as part of upgrade
    • Was this article helpful?

    Recommended articles

    1. Article type
      Topic
      Language
      English
      Product
      Aleph
    2. Tags
      1. 20
      2. contype:kba
      3. Prod:Aleph
      4. Type:General
      5. Upgrade
    1. © Copyright 2025 Ex Libris Knowledge Center
    2. Powered by CXone Expert ®
    • Term of Use
    • Privacy Policy
    • Contact Us
    2025 Ex Libris. All rights reserved