Browse search for call number retrieves "No browse records found"
- Article Type: General
- Product: Primo
- Product Version: 4
Problem Symptoms:
- Browse search is working for author, title, and subject
- "Call Number" field exists in the PNX with the correct institution code
- Any call number browse search retrieves "No browse records found"
Cause:
Spaces in browse/callnumber field.
For example: <callnumber>$$IPRIMO $$Dnp17785 $$Enp17785</callnumber>
Resolution:
1. In the Back Office, go to Advanced Configuration > Full Normalization Rule Configuration and edit the Normalization Rules (NR) set
2. Remove the spaces between the rules in browse/call number
3. Save and deploy the set
4. Run an index
Additional Information
* Browse call number isn't normalized during indexing and the following sub fields are being indexed as they are: $$I, $$E, $$T.
* Therefore, when spaces exists in this field, the institution is being indexed with the space after the institution (for example, "$$PRIMO ").
* Since the institution code in the search section doesn't have those spaces, there isn't a match and the record is not retrieved.
Category: Front End - Primo
Subject: Browse - Primo
- Article last edited: 12/2/2013