Browse search retrieves huge number of records in Call Number Browse
- Article Type: General
- Product: Primo
- Product Version: 4.7
Problem Symptoms:
- A large number of records contain the same value for browse/callnumber
- Browse search returns a huge number of results
Cause:
A large number of records contain the same value for the browse/callnumber field of the PNX. This is often a generic value such as "internet" or "microform."
Resolution:
Add a condition to all normalization rules for browse/callnumber:
Advanced Configuration > Full Normalization Rule Configuration > PNX Section: Browse > Field: Call Number
Conditions Logic: True
Condition 1:
- Logic: False
- Source: <field and sub-field in which call number is included> - for example, 949 d
- Success if : Match Current
- Routine: Check string equals string/<string> - for example, MICROFORM
Additional Information
This issue is fixed in Primo version 4.8. After the fix, the system will only display up to 150 records that are linked to the same call number in the Browse index to prevent a system crash.
Category: Front End - Primo
Subject: Browse - Primo
- Article last edited: 11/21/2017