No Primo Central Results After Upgrade to New Server
- Article Type: General
- Product: Primo
Problem Symptoms:
When searching the PC scope in Primo, the following error message appears:
?€œAn unexpected error has occurred?€?
Cause:
Possible Causes:
1. New environment IP is not authorized in Primo Central
2. Error in thirdnode-config.xml
Resolution:
Cause 1. New environment IP is not authorized in Primo Central
1. From the Primo BE, go to Primo Home > Ongoing Configuration Wizards > Institution Wizard
2. Choose the relevant institution
3. Click on ?€œMyProfile?€?
4. Click on ?€œMy Client Applications?€?
5. Choose the relevant institution
6. Click on ?€œEdit FE IP Addresses?€?
7. Under ?€œIP Address?€?, add all the IP addresses of the new server. One address per line.
8. Click on ?€œSubmit Changes?€?
9. Wait for 3 hours
Cause 2 Error in thirdnode-config.xml
1. Go to a specific FE (not a load balancer) and perform a search. It should fail.
2. On the server, check the fe_log (library_server.log) for near the end of the file for an error message related to thirdnode-config.xml
Sample error message: 2014-08-22 12:19:24,400 ERROR [t-http-bio-1701-exec-88] [c-TNConfigurationManager] - Failed to init thirdnode config, error: error: </adaptor_config> does not close tag <parameters>.
3. Review thirdnode-config.xml in the fe_conf directory for the error indicated in the log (unmatched <parameters> entries in this example).
4. Save changes and test.
Category: PC via Primo
- Article last edited: 8/29/2014