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    Pipe cannot load the new files

    • Article Type: General
    • Product: Primo
    • Product Version: 4

    Problem Symptoms:
    1) Pipe cannot load the new files and gives message "No updated files were found" and "No files were found"

    Below is an example of related logs showing the problem symptoms.
    ===========================
    2014-07-06 18:31:59,296 INFO [t-HarvestByCopy] [c-AbstractHarvester] - File list after sort: /exlibris/primo/p4_1/ng/primo/home/system/tomcat/search/webapps/primo_library#libweb/data_sources/MARC_8111_0414.zip
    2014-07-06 18:31:59,297 INFO [t-HarvestByCopy] [c-AbstractHarvester] - File: [/exlibris/primo/p4_1/ng/primo/home/system/tomcat/search/webapps/primo_library#libweb/data_sources/MARC_8111_0414.zip] File date: [Mon Jul 07 14:26:59 CDT 2014] Start: [2014-06-02 12:59:55.0] End: [Sun Jul 06 18:31:59 CDT 2014]
    2014-07-06 18:31:59,297 WARN [t-HarvestByCopy] [c-AbstractHarvester] - No updated files were found in the /exlibris/primo/p4_1/ng/primo/home/system/tomcat/search/webapps/primo_library#libweb/data_sources directory
    2014-07-06 18:31:59,297 INFO [t-HarvestByCopy] [c-CopyHarvester] - All files copied.
    2014-07-06 18:31:59,297 INFO [t-HarvestByCopy] [c-AbstractHarvester] - No files were found. Stopping.
    ======================

    Cause:
    The server time is behind the actual time.
    The new files that pipe FTP'ed to the server have timestamps of actual time.
    The pipe looks for new files up to the present time on the server, and cannot find the files with "future" time.

    Resolution:
    Change the server time to actual time.

    Category: Primo - Pipe

    Subject: Pipes


    • Article last edited: 8/5/2014
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