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    4. Primo Call Numbers Disappear

    Primo Call Numbers Disappear

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    1. Additional Information
    2. Local Customers
    3. Direct, Direct-Dedicated, and Total Care Customers
    • Article Type: General
    • Product: Primo
    • Product Version: Jul-15
    • Relevant for Installation Type: Direct; Local;

    Problem Symptoms
    - All-In-One topology
    - After searching in the Primo Front End each record displays availability information, including call number and "(updating...)" for local resources
    - After a delay of at least 20 seconds both the availability information, including call number and "(updating...)" disappear
    - The Locations Tab is blank
    - There are no calls to /primo_publishing/admin/webservices/services/NormalizeRecord in the localhost_access_log.<DATE>.txt located in the fe_log directory
    - The /etc/hosts file does not contain an entry for the host name, or it is commented out with #
    - The library_server.log in the fe_log directory contains the following error:

    2015-10-07 12:02:26,532 ERROR [t-http-bio-1701-exec-979] [c-AbstractRtaAdaptor] [O -(2000001,2221346,null)] - Failed to invoke webservice. The reason is: ; nested exception is:
    java.net.SocketTimeoutException: Read timed out
    AxisFault
    faultCode: {http://schemas.xmlsoap.org/soap/envelope/}Server.userException
    faultSubcode:
    faultString: java.net.SocketTimeoutException: Read timed out
    faultActor:
    faultNode:
    faultDetail:
    {http://xml.apache.org/axis/}stackTrace:java.net.SocketTimeoutException: Read timed out
    at java.net.SocketInputStream.socketRead0(Native Method)
    at java.net.SocketInputStream.read(SocketInputStream.java:152)
    at java.net.SocketInputStream.read(SocketInputStream.java:122)
    at java.io.BufferedInputStream.fill(BufferedInputStream.java:235)
    at java.io.BufferedInputStream.read(BufferedInputStream.java:254)
    <snip>
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
    at java.lang.Thread.run(Thread.java:745)

    {http://xml.apache.org/axis/}hostname:<HOSTNAME>

    java.net.SocketTimeoutException: Read timed out
    at org.apache.axis.AxisFault.makeFault(AxisFault.java:101)
    at org.apache.axis.transport.http.HTTPSender.invoke(HTTPSender.java:154)
    at org.apache.axis.strategies.InvocationStrategy.visit(InvocationStrategy.java:32)
    <snip>
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
    at java.lang.Thread.run(Thread.java:745)
    Caused by: java.net.SocketTimeoutException: Read timed out
    at java.net.SocketInputStream.socketRead0(Native Method)
    at java.net.SocketInputStream.read(SocketInputStream.java:152)

    Cause
    This error will occur if the server's host name is not in /etc/hosts.

    Resolution
    1. Login to the server
    2. Become the root user
    3. Make a backup of the /etc/hosts file
    4. Update the /etc/hosts file to contain an entry for the server's host name

    Additional Information

     

    Local Customers

    If any clarification is needed on the instructions please open a case.

    Direct, Direct-Dedicated, and Total Care Customers

    Due to no server or root access please open a case with Support

    Category: Front End

    Subject: Availability/RTA


    View article in the Exlibris Knowledge Center
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    1. Article type
      Topic
      Community Content Type
      How To
      Content Type
      Knowledge Article
      Language
      English
      Product
      Primo
    2. Tags
      1. Availability/RTA
      2. contype:kba
      3. Direct
      4. Front End
      5. Jul-15
      6. Local
      7. Prod:Primo
      8. Type:General
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