Primo New UI view is not loading correctly
- Product: Primo
- Product Version: August 2016 release
- Relevant for Installation Type: Dedicated-Direct, Direct, Local
Symptoms
There are several possible symptoms to this issue. When trying to open the new Primo UI:
- The page is not loading at all
- Some elements are missing from the page
- The view is corrupted
- Tabs are not loading correctly
Cause
One (or more) of the view's tiles were not configured (e.g no search fields were chosen).
Solution
- Go to the Primo Back Office > Ongoing Configuration Wizards > Views Wizard
- Edit the relevant View
- Click Save and Continue until you get to the Tiles Configuration page
- Edit and Save every tile on all three pages:
- Home Page
- Basic Search
- Advanced Search
- Main Menu
- Static HTML
- Full Display
- Full Results
- Send To
- Brief Display
- Brief Results
- Refine My Results (Facets)
- Locations
- Home Page
- Deploy the View
- Article last edited: 13-Oct-2016