Viewing My Account returns ILS errors
- Article Type: General
- Product: Primo
- Product Version: 4
Problem Symptoms:
?€¢ Select "Personal Settings" under "My Account", it returns the error message "We're sorry, but an unrecoverable problem was detected trying to call the ILS system. Try again later."
?€¢ Save a search query. It is not saved and cannot be seen in My Account.
?€¢ Other functions/tab appear to be working fine at "My Account"
?€¢ Http exception found in the FE_LOG
when calling ILS: HTTP/1.1 405 Method Not Allowed
serviceName:'get_patron_information' ; method:'http://voyager.xxxx.edu:7014/vxws/patron/19286/patronInformation/address?patron_homedb=1@XXXDB20020711105036'
Cause:
Invalid Parameter Value in ILS Templates Parameters
Resolution:
1. Invalid entry/method in mapping table: ILS Gateway > ILS Templates Parameters:
ID Parameter Name Parameter Value Description
70009 HTTP Action POST get_patron_information
2. Delete the entry
3. Deploy the change in BO
Other Information
HTTP Error 405 Method not allowed
http://www.checkupdown.com/status/E405.html
Category: OPAC via Primo
Subject: My account
- Article last edited: 10/8/2013