SIPs locked after updateRepresentation
- Article Type: General
- Product: Rosetta
Problem Symptoms:
After updateRepresentation (ADD file) a SIP was locked, and needed to be unlocked by support.
The new fileIDs are not in the METS record and are not searchable.
No new METS version was created - only 1 version
Cause:
When a record is manually unlocked, some previous processes are rolled back and not created.
Therefore when unlocking a record we need to verify the process was completed or re-run it.
Resolution:
A new METS version was not created, by creating a new version - a new METS is created AND the record is being indexed again.
To create a new version:
1. Select the IE and lock it.
2. Create new mets version - e.g. assign AR or update MD.
3. Commit
4. Now the METS version contains all the files.
Category: Rosetta
- Article last edited: 5/7/2014