MARCit! enhanced file is not FTPd back to /export directory
- Article Type: General
- Product: SFX
- Product Version: 4
Problem Symptoms:
During the MarcIt! export run, the export file is generated, but an error message is returned from the MarcIt server:
The MARCIt! process failed:
Cannot enhance (ERROR=Cannot determine local file on server).
Please report this failure through the CRM eService.
http://support.proquest.com/
Cause:
Firewall rules for MARCit!-related ports need to be adjusted on the server
Resolution:
The following tasks need to be completed by the server administrator or the library IT team:
1) Open outgoing HTTP ports 8999 and 8991.
2) Set the TCP timeouts for these ports to 14400 seconds (4 hours).
Additional Information
More information on MARCit! export workflow:
* SFTP connection is opened from SFX customer server to MARCit! server, export file is transferred from customer server to MARCit! server for enhancement.
* HTTP connection is opened from SFX customer server to MARCit! server.
* Request for action on the MARCit! server is sent
* Enhancement process on MARCit! server begins (2+ hours).
* HTTP connections should remain open during this time.
* When enhancement completes, MARCit! server sends a response back to SFX customer server.
* SFTP connection is opened from customer server to MARCit! server, enhanced file is transferred to /export directory on customer's SFX Instance.
Category: MARCit! (SFX)
Subject: SFX
- Article last edited: 10/24/2013