'Valid circulation calendar not found' error when attempt charge or renewal of items
- Product: Voyager
- Product Version: all
- Relevant for Installation Type: Multi-Tenant Direct, Dedicated-Direct, Local, TotalCare
Problem Symptoms
When attempting to charge or renew an item in Circulation, a pop-up message stating 'Valid circulation calendar not found. Please consult the System administrator.' displays and the charge/renew fails
Cause
This problem will occur if the due date the system is trying to apply is not included in a Calendar selected in the related Circ Policy Definition in SysAdmin>Circulation>Policy Definitions>[policy in question]>Calendars tab
Resolution
1. In SysAdmin>Circulation>Calendars, make sure you have a calendar that contains the desired due date (generally speaking, make sure each new Calendar begins the day immediately after the end date of the last calendar, leaving no gaps; closed days can be accounted for with Exception Dates)
2. In SysAdmin>Circulation>Policy Definitions, in the Calendar tab of the Policy in question, make sure all appropriate Calendars are moved from the Available to the Selected section
3. Log out of Circulation, and then back in for policy changes in SysAdmin to take effect
- Article last edited: 10-Sep-2021