BulkImport log contains "ERROR: Record do not match format ..."
- Product: Voyager
- Product Version: All
- Relevant for Installation Type: Total Care; Dedicated-Direct; Direct; Local
Problem Symptoms:
- Log from BulkImport job contains an error beginning with "ERROR: Record do not match format"
- The BulkImport job will not start.
Cause
Expected character set in BulkImport rule does not match character set encoding of records being imported.
Resolution
Use different character set encoding:
- Go to SysAdmin > Cataloging > Bulk Import Rules
- Highlight bulk import rule; click Edit.
- Rules tab > Expected Character Set Mapping of Incoming Records
- Change to character set compatible with record file.
Additional Information
If you do not know the character encoding for your records, finding the correct set may require multiple changes to the import rule's Expected Character Set to find the correct one. Often, record vendor can provide character set encoding information. Popular character sets include Marc21 UTF-8, Marc21 MARC-8, and OCLC (non-unicode).
Variations of the error message include:
"ERROR: Record do not match format for 'A' change your import rule"
"ERROR: Record do not match format for 'U' change your import rule"
"ERROR: Record do not match format for 'L' change your import rule"
- Article last edited: 13-Apr-2016