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    4. BulkImport stops when encountering unparseable record

    BulkImport stops when encountering unparseable record

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    1. Additional Information
    • Article Type: General
    • Product: Voyager
    • Product Version: 8.1.1

    Problem Symptoms:
    * When Bulk Import encounters a character during import that it cannot convert, it logs the conversion error and the import stops. The record is not written to the error file and no additional records are imported.
    * log.imp* file records error:
    "ERROR: Unparseable record written to error file" followed by character position and encoding of nonconvertible character

    Cause:
    This behavior is the result of Known Issue 16384-17538.

    Resolution:
    Fixed for Voyager 8.1.2 and higher.

    Additional Information

    Hotfix available for Voyager 8.1.1. Open an incident with Voyager Support if you believe you are experiencing this issue.

    Replication steps:
    1. Take the attached file of authority records and put it on your server in /m1/incoming (or PC if using WebAdmin).
    2. Create a bulk import rule with the Expected Character Set of MARC21 MARC-8, and set it to load Bibs, Auths only. Name it MARC8.
    3. From the /sbin directory for your instance, run the bulk import:
    Pbulkimport ?f/m1/incoming/BadRecords.mrc ?iMARC8
    4. Find the log.imp* file for your import. Note that the import stops when it encounters a character it cannot convert, and that the err.imp* file is empty.

    Other information: In previous versions of Voyager, the record was written to the error file.

    Workaround: None. If available, can use a MARC editor to convert the records to UTF-8 prior to import, or request records with MARC21 UTF-8 encoding from vendor.

    Category: Batch jobs


    • Article last edited: 10/8/2013
    View article in the Exlibris Knowledge Center
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    2. Tags
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