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    4. InterCirc/NCIP unable to process item barcodes containing special characters

    InterCirc/NCIP unable to process item barcodes containing special characters

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    1. Additional Information
    • Article Type: General
    • Product: Voyager
    • Product Version: 8.2.0

    Problem Symptoms:
    ? Relais sends request to Voyager that includes barcode that contains a special character; InterCirc does not recognize the barcode, and returns error messages that indicate an error with NCIP server.

    Cause:
    This behavior is a result of Issue VYG-4851.

    Resolution:
    Issue VYG-4851 is resolved for Voyager 9.0.0 and higher.

    Additional Information

    Workflow Implications
    Staff must replace each barcode that contains special character with different barcode (no special characters included) prior to processing request via Relais.

    Replication steps
    1. Create Ship Loan request in Relais for Voyager item that has barcode that includes special character (i.e., 00000967773$).

    2. Attempt to process request.

    3. Receive error in Relais interface: "Unable to Checkout Item. ERROR from NCIP server: ItemIdentifierValue - Unknown Item - 00000967773$"

    4. Receive errors in catalina.out:
    "25248712 [http-bio-10963-exec-7] ERROR UserLog - : 00000967773$"
    "25248712 [http-bio-10963-exec-7] ERROR UserLog - Responding with NCIP problem report: Unknown Item at NCIPMessage.CheckOutItem.UniqueItemId.ItemIdentifierValue, value=00000967773$"

    5. Note that in ncip-traffic log, request is sent:
    <?xml version="1.0" encoding="UTF-8" ?><NCIPMessage version="http://www.niso.org/ncip/v1_0/imp1/dtd/ncip_v1_0.dtd"><CheckOutItem><In
    itiationHeader><FromAgencyId><UniqueAgencyId><Scheme>http://www.relais-intl.com/ncip/schemes/agency.scm</Scheme><Value>Relais</Value
    ></UniqueAgencyId></FromAgencyId><ToAgencyId><UniqueAgencyId><Scheme>http://www.relais-intl.com/ncip/schemes/agency.scm</Scheme><Val
    ue /></UniqueAgencyId></ToAgencyId></InitiationHeader><UniqueUserId><UniqueAgencyId><Scheme>http://www.relais-intl.com/ncip/schemes/
    agency.scm</Scheme><Value /></UniqueAgencyId><UserIdentifierValue>00000980966</UserIdentifierValue></UniqueUserId><UniqueItemId><Uni
    queAgencyId><Scheme>http://www.relais-intl.com/ncip/schemes/agency.scm</Scheme><Value /></UniqueAgencyId><ItemIdentifierValue>000009
    67773$</ItemIdentifierValue></UniqueItemId><UniqueRequestId><UniqueAgencyId><Scheme>http://www.relais-intl.com/ncip/schemes/agency.s
    cm</Scheme><Value>Relais</Value></UniqueAgencyId><RequestIdentifierValue>UPN-10380260</RequestIdentifierValue></UniqueRequestId></Ch
    eckOutItem></NCIPMessage>

    6. But in ncip-traffic log, the response indicates that item is not recognized:
    <NCIPMessage version="http://www.niso.org/ncip/v1_0/imp1/dtd/ncip_v1_0.dtd">
    <CheckOutItemResponse>
    <ResponseHeader>
    <FromAgencyId>
    <UniqueAgencyId>
    <Scheme>http://www.relais-intl.com/ncip/schemes/agency.scm</Scheme>
    <Value>VOYAGER</Value>
    </UniqueAgencyId>
    </FromAgencyId>
    <ToAgencyId>
    <UniqueAgencyId>
    <Scheme>http://www.relais-intl.com/ncip/schemes/agency.scm</Scheme>
    <Value>Relais</Value>
    </UniqueAgencyId>
    </ToAgencyId>
    </ResponseHeader>
    <Problem>
    <ProcessingError>
    <ProcessingErrorType>
    <Scheme>http://www.niso.org/ncip/v1_0/schemes/processingerrortype/checkoutitemprocessingerror.scm</Scheme>
    <Value>Unknown Item</Value> <---------ITEM IS NOT RECOGNIZED
    </ProcessingErrorType>
    <ProcessingErrorElement>
    <ElementName>UniqueItemId</ElementName>
    <ProcessingErrorElement>
    <ElementName>ItemIdentifierValue</ElementName>
    <ProcessingErrorValue>00000967773$</ProcessingErrorValue>
    </ProcessingErrorElement>
    </ProcessingErrorElement>
    </ProcessingError>
    </Problem>
    </CheckOutItemResponse>
    </NCIPMessage>

    7. Request fails.

    Workaround
    Replace barcodes that contain special characters with barcodes that do NOT contain special characters.

    Category: (Voyager) - Voyager

    Subject: Voyager


    • Article last edited: 5/14/2014
    View article in the Exlibris Knowledge Center
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