Jobs in GDC queue never start
- Product: Voyager
- Product Version: 8.0.0
- Relevant for Installation Type: Dedicated-Direct; Direct; Local
Problem Symptoms
Jobs in Global Data Change Job Queue are never started - jobs just sit in the queue
GDC jobs with a start time of "now" should usually start within a few minutes. There is a job scheduler function that checks the queue regularly, and typically a job that was submitted should start within 5 minutes or less. Note however that only one job at a time will run, so new jobs queue up behind a running job. In some situations jobs can get "stuck" and additional jobs will not run (an example of this is when an operator attempts to KILL a job but it does not transition to KILLED status). Contact Support if you suspect you may have a problem like this.
Cause
jobd isn't running on the server for the Voyager database instance (xxxdb).
Resolution
- Connect to server via SSH or Telnet.
- ps -ef | grep jobd
- If there is no process for xxxdb listed, start the process:
- cd /m1/voyager/xxxdb/sbin
- ./Pjobd
- Check that process is running for xxxdb: ps -ef | grep jobd | grep xxxdb
Additional Information
If step 3.b. results in "Jobd is running on xxxdb. Please kill PID {PID} and restart the Pjobd program"
- Check for the referenced process: ps -ef | grep {PID} [where {PID} is the PID in the message]. If a process with that PID is not running, continue.
- cat /m1/voyager/xxxdb/log/jobd.pid
- If the jobd.pid contains the PID from the message, then remove the jobd.pid file: rm -i jobd.pid
- Start jobd: /m1/voyager/xxxdb/sbin/Pjobd
If the process does not start, does not remain running after it's started, or Voyager server access is not available (Voyager TotalCare customers, for example), please open a Case with Support.
Article last edited: 10-Mar-2016