Skip to main content
ExLibris

Knowledge Assistant

BETA
 
  • Subscribe by RSS
  • Back
    Voyager

     

    Ex Libris Knowledge Center
    1. Search site
      Go back to previous article
      1. Sign in
        • Sign in
        • Forgot password
    1. Home
    2. Voyager
    3. Knowledge Articles
    4. VXWS: circulationActions - Loans allows unlimited renewals

    VXWS: circulationActions - Loans allows unlimited renewals

    1. Last updated
    2. Save as PDF
    3. Share
      1. Share
      2. Tweet
      3. Share
    1. Additional Information
    • Article Type: General
    • Product: Voyager
    • Product Version: 7.2.0

    Problem Symptoms:
    * Transaction Related Exceptions report includes "Renewal Limit Overrides" with an Operator ID of "OPAC"
    * Patron on report has more renewals for item than allowed in Circulation Policy Matrix
    * The Patron Circulation Actions ? Loans API can be used to renew an item an unlimited number of times, regardless of what?s in the Circulation Policy Definitions.

    Cause:
    This behavior is caused by Known Issue 16384-13841.

    Resolution:
    Issue 16384-13841 is resolved for Voyager 8.1.1 and higher.

    Additional Information

    Replication steps:
    1. In SysAdmin, go to Circulation -> Policy Definitions, then edit the policy by going under Matrix, and for the applicable item type/patron group, ensure that a maximum number of renewals is set
    2. In Circulation, charge an item to a patron record, and ensure both fall under the policy definition used in step 1
    3. Renew the item from step 2 as many times as you can, until greeted with a message saying the maximum number of renewals has been reached
    4. Submit a POST request to the Patron Circulation Actions ? Loans service to renew the item, e.g. http://10.100.2.37:30314/vxws/patron/204/circulationActions/loans/1@GWCCDB20010402131061%7C8465?patron_homedb=1@DMADB20010103091142
    5. The system will send back XML with a <renewalStatus> tag showing ?Success?. If you check Circulation, looking at the item?s counters, you?ll see the item has in fact been renewed again.

    Workaround: The API sends back XML data which includes a ?canRenw? tag. If it?s equal to ?N?, the item cannot be renewed. Any web site that uses this API should check the contents of this tag before submitting a renewal.

    Other Information: This behavior also occurs for any blocks that should prevent a patron from renewing. This includes blocks that should originate from the Policies, Patron and Matrix tabs of Policy Definitions and Global Item Limits in the Patron Group area of SysAdmin. Patrons that have these blocks applied are still able to renew.

    Category: Opac


    • Article last edited: 10/8/2013
    View article in the Exlibris Knowledge Center
    1. Back to top
      • vxws: Call Slip API uses Patron settings from item policy
      • vxws: confusing error message when call slip fails
    • Was this article helpful?

    Recommended articles

    1. Article type
      Topic
      Language
      English
      Product
      Voyager
    2. Tags
      1. voy-resolved-8
    1. © Copyright 2025 Ex Libris Knowledge Center
    2. Powered by CXone Expert ®
    • Term of Use
    • Privacy Policy
    • Contact Us
    2025 Ex Libris. All rights reserved