We use Springshare LibGuides and sometimes the OPAC becomes unresponsive
- Product: Voyager
Problem Symptoms
- Enrolled in Springshare LibGuides (http://springshare.com/libguides/)
- OPAC/Webvoyage and/or other modules become slow, unresponsive, or unavailable at times
- Many HTTP HEAD requests from the IP addresses, 174.132.16.36 and/or 174.132.33.114, logged in the Apache access log (/m1/shared/apache2/logs/xxxdb/access.log)
Cause
The link checker software run by LibGuides can overwhelm a Voyager server by making too many concurrent requests. Each request spawns a new OPAC session. Eventually, the number of sessions reaches the Voyager license limit and further connections are blocked.
Resolution
Ex Libris is working with Springshare to improve the behavior of their link checking software.
To prevent the spider software from indexing your library, perform one of the following options:
- Submit a request to LibGuides to remove your links from its link checker
- Block the spider's IP address (174.132.16.36) at your firewall
- Article last edited: 26-Nov-2013