Skip to main content
ExLibris
  • Subscribe by RSS
  • Ex Libris Knowledge Center

    z39.50 search on title returns "An error was encountered while performing the z39.50 query"

    • Product: Voyager
    • Product Version: All
    • Relevant for Installation Type: Dedicated-Direct, Direct, Local, Total Care

    Problem symptoms

    When a third-party client attempts to search Voyager via z39.50 by title, the search returns the following:

    An error was encountered while performing the Z39.50 query: 
    UnsupportedSearch (Voyager) 

    Cause

    The z39.50 configuration in the client is conducting a keyword search across multiple subfields (@attr 1 = 4). Keyword indexing is based on individual field/subfield combinations; the client is searching the full title (245 subfields a and b) and should be configured to query as a left-anchored search.

    Resolution

    1. Review the configuration for the search in the client.
    2. Update configuration to include position and truncation attributes. For example: @attr 1=4 @attr 3=1 @attr5=1
    3. Save changes and try searching again.

    Additional information

    See https://www.loc.gov/z3950/agency/defns/bib1.html for more information on the z39.50 search attributes above.


    • Article last edited: 15-Feb-2016
    • Was this article helpful?