Skip to main content
ExLibris
Ex Libris Knowledge Center

ARC 4 - CM-REQ-4139 when trying to Import the content store

Symptoms

CM-REQ-4139 

"all_content_arc_3" is not a valid deployment archive. 

Details 
javax.crypto.BadPaddingException: Given final block not properly padded

Defect Status

IBM issue with DK 7.0_71 and above . IBM will fix in future version of Cognos. 

Replication Steps

Import Content store to ARC 4.0 and Select the deployment in Content Admin

Workaround

A: First export the Customized reports. Do not export the entire content store. Then the export should work. 

or

B: Customer had JDK 7.0_79. They installed and older version of Java (JDK 7.0_67) and the import worked. 

(note: do not delete the original JDK, it may be needed in the future). 

 

 

  • Product: ARC 
  • Product Version: 4
  • Relevant for Installation Type: all

 

 

 

 


  • Article last edited: 09-02-2016