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    After installing v21 Minor Release (SP 2278), Version Check doesn't work

    • Article Type: General
    • Product: Aleph
    • Product Version: 21

    Problem Symptoms:
    After installing the v21 Minor Release (SP 2278), Version Check doesn't work:

    1. "Failed to read reply" or

    2 Version Check seems to be downloading files, but doesn't actually do anything: each time you do Version Check again, it shows the same files being downloaded.


    *And* all of the following fail:

    * "Error 0015 Not defined in file pc_job_c1201" message in Task Manager when FileList is clicked on
    * In Circ, clicking on Local Patron Info causes the client to crash
    * In Search in any module, clicking on "Show" causes the client to crash

    Cause:
    The alephcom.ini "[Version Control] Library=" parameter specifies a library whose library.ini entry is commented out or points to the wrong server. Example: it specifies "Library=USM01", and the library.ini entry for USM01 points to the Ex Libris (il-aleph20) server, or to your Prod server, when it should be Test -- or vice versa.

    The failures occur because the new .exe's have not been brought in by Version Check.

    Resolution:
    If the PC's alephcom.ini has Library=USM01, change it to Library=XXX01 (where XXX01 is your local bib library).

    Make sure that all of the following library.ini entries are pointing to the correct server:

    the ALEPH line
    the PCVER line
    the XXX01 line

    If you are executing the GUI using a desktop icon, it may be pointing to the wrong file. Instead of using the icon, execute the GUI c;ient from the Windows navigator: that is: go up two levels from the .Alephcomtab to .Circ, .Cat, or .Acq; then go to the .bin directory; and click on the xxxx.exe file in that directory to start up the client.

    Additional Information

    There have been cases where, after Version Check, the new .exe file is present but with a ".upg" suffix, and the previous .exe is not replaced. If this is just a single .exe, the explanation may be found in KB 16384-57651 ("Why are .exe files with ".upg" suffix created?"), but there has been at least one case where *all* of the .exe's had the .upg suffix. In this case, a reinstall of the GUI, using the ./pc_exe/gui500.exe from the server, was required.

    Category: Installation & Upgrades (500)

    Subject: Service Pack (500)


    • Article last edited: 10/8/2013