Inconsistent viewing of expired holds in GUI
- Article Type: General
- Product: Aleph
- Product Version: 20
Problem Symptoms:
In viewing reports of expired hold requests, Circulation staff are finding they can sometimes view the request by scanning the item barcode in Circulation, making sure the Non-Active Requests box is checked. But other times, the expired hold does *not* appear.
In each case, they have been able to successfully look up the request via the Patron record, and then they "go to item, -- but this is an inconvenience for the staff.
There are no apparent differences between the holds which can be accessed via item barcode and those which can not.
Cause:
Duplicate item barcodes (for items created via NCIP). (Accessing the item via barcode was bringing up a different item with the same barcode. No request exists for that item.)
Resolution:
Make barcode of NCIP item unique.
Additional Information
The z30_id1 is defined in Oracle as NONUNIQUE -- so there's really nothing enforcing uniqueness. (z30 is the item record.)
- Article last edited: 1/8/2014