Skip to main content
ExLibris
  • Subscribe by RSS
  • Ex Libris Knowledge Center

    Lack of Service Pack level in GUI -> Help -> About... -> "Server Version"

    • Article Type: Q&A
    • Product: Aleph
    • Product Version: 20

    Question

    Does the lack of the Service Pack level in the GUI -> Help -> About... "Server Version" indicate a need to apply a Service Pack?
    The "ver" command on the server shows "22.0.1 (35)", while the GUI -> Help -> About... -> "Server Version" has only "22.0.1" -- no Service Pack level in parentheses.

    Answer

    The following shows what service packs have been applied to the server:

    > cd $aleph_root/../service_pack
    > ls -lrt

    If this shows that the current Service Pack is installed, there is no need to install any Service Packs.

    The GUI -> Help -> About... -> "Server Version" can be a bit erratic. The "ver" command on the server shows the server SP level; GUI -> Help -> About... "GUI Version" shows the GUI SP level. If these match, that's all that matters.

    Additional Information

    If the GUI -> Help -> About... -> "GUI Version" is *lower* than the "ver" command version seen on the server, that indicates a need to do Aleph -> Version Check in the GUI.


    • Article last edited: 4/18/2014